Back to overview
Degraded

Upstream Issues

Jul 27 at 06:12pm BST
Affected services
EU01 Game Hosting
UK01-HYBRID-7950X

Resolved
Jul 27 at 06:42pm BST

Everything appears to be stable now we haven't seen any drops for the past 30 minutes, our provider has two new ports lined up to help prevent this issue in future

Created
Jul 27 at 06:12pm BST

Our current provider in the UK01 Location is experiencing issues with it's upstream we'll keep you updated as we hear more from them