Back to overview
Resolved

Upgrading billing system

Jun 20, 2026 at 4:45am UTC  –  Jun 20, 2026 at 9:00am UTC
Affected services
Site & Billing Portal

Resolved
Jun 20, 2026 at 9:00am UTC

Maintenance ended

Created
Jun 20, 2026 at 4:45am UTC

We will be taking our billing system offline temporarily to perform needed upgrades on the server